#444 Issue closed: rear rescue ISO image kernel panic

Labels: support / question

kamensa opened issue at 2014-07-29 10:09:

Hi All,

I have installed REAR on RHEL 6.5 - 2.6.32-431.el6.x86_64, physical box and RHEL 5.10 - 2.6.18-371.el5 i686 - VM on VirtualBox. REAR versions which I have used are rear-1.16.1-1.el5 and rear-1.15-9.el6.noarch. The backup process completes without any issues. I'm using NFS share for backup and iso files but when I try to boot from rescue image I get kernel panic. The same result on physical box and VM. Could you tell me how to attached my local.conf, site.conf and rear log file here? Basically I have copied default.conf into /etc/site.conf and changed the following:


The /etc/rear/local.conf contains: OUTPUT=ISO

The /etc/rear/os.conf contains:

Here are the kernel panic snapshots:



gdha commented at 2014-07-29 14:11:

which fs type are you using? ext3 perhaps. it might be the the ext3 kernel module is not loaded during the initrd phase...

kamensa commented at 2014-07-30 06:50:

How could I fix this? I mean how could I force rear mkbackup or rear mkrescue to include this module. I have used rear couple of years before and I haven't had such issues. It's very strange to have issues with ext3 fs.

gdha commented at 2014-07-30 09:05:

See the issues #326 and #367 for some background details. You could start with lsmod | grep ext on your running system (and on the system booted with recovery image)

kamensa commented at 2014-07-30 12:25:

I have used ext4 on RHEL6 and ext3 on RHEL5. I'm going to try to load respective modules with MODULES_LOAD array using site.conf file tomorrow:

[root@ausrhdb501 ~]# lsmod |grep -i ext
ext4 374902 3

[root@vmrear_test ~]# lsmod|grep ext
ext3 126281 2

kamensa commented at 2014-07-31 10:03:

I have tried to load the ext3 module on RHEL5 VM but with no success. I have used two different ways for syntax:

MODULES_LOAD=( ext3 ) and MODULES_LOAD=( ${MODULES_LOAD[@]} ext3 )

gdha commented at 2015-08-07 09:07:

@kamensa Sorry for the delay...
The MODULES_LOAD=( ${MODULES_LOAD[@]} ext3 ) is the correct definition.
Did you try the latest rear-1.17.1?

gdha commented at 2015-09-23 12:09:

death case I'm afraid

[Export of Github issue for rear/rear.]