#457 Issue closed: Can't recover my Oracle Linux server with Netbackup (NBU) using Rear.

Labels: support / question

kichoc opened issue at 2014-09-09 03:17:

I’m having issues recovering an Oracle Linux server with Rear and NBU.
I have no issues recovering this same Oracle Linux server with Rear and Netfs but when I try with NBU the recover process seems to work (see below)

08:36:06 (67385.001) chmod 555 /mnt/local/usr/share/empty to reset permissions.
08:36:07 (67385.001) chmod 511 /mnt/local/var/run/cups/certs to reset permissions.
08:36:07 (67385.001) chmod 600 /mnt/local/var/opt/VRTSsfmh/vea to reset permissions.
08:36:07 (67385.001) chmod 600 /mnt/local/var/opt/VRTSsfmh/veaintf to reset permissions.
08:36:21 (67385.001) INF - TAR EXITING WITH STATUS = 0
08:36:21 (67385.001) INF - TAR RESTORED 139769 OF 139769 FILES SUCCESSFULLY
08:36:21 (67385.001) INF - TAR KEPT 0 EXISTING FILES
08:36:21 (67385.001) INF - TAR PARTIALLY RESTORED 0 FILES
08:36:22 (67385.001) Status of restore from image created 08/26/14 15:34:39 = the requested operation was successfully completed
08:36:24 (67385.xxx) INF - Status = the requested operation was successfully completed.

But when I go to reboot the server it does not boot with the below errors.


There is no console login prompt after the reboot and can’t ping the server so it doesn’t seem to restore networking etc.
Has anyone seen this before?

I’m running
Netbackup server 6.5.5
Netbackup client 6.5
Oracle Linux Server release 5.7

Also tried it on:
Netbackup server 7.5
Netbackup client 7.0
using rear-1.16.1-1
and has the same result.

Here is my local.conf
COPY_AS_IS_NBU=( /usr/openv/bin/vnetd /usr/openv/bin/vopied /usr/openv/lib /usr/openv/netbackup /usr/openv/var/auth/[mn].txt )
COPY_AS_IS_EXCLUDE_NBU=( "/usr/openv/netbackup/logs/
" "/usr/openv/netbackup/bin/bpjava*" "/usr/openv/netbackup/bin/xbp" )
PROGS=( "${PROGS[@]}"
ssh-keygen )

I’m trying to recover from a Netbackup full backup including /boot and /.
I have also tried performing the backup using “ALL_LOCAL_DRIVES” and /boot which exhibits the same problem.
I can restore single files onto this client through bprestore so I know netbackup is working as it should.
One thing I have noticed is that there is no relabeling performed when I recover with NBU compared to Netfs which always performs a relabel on initial reboot after the recover.
Not sure if this should be the case or not?
Any help will be appreciated as I don’t think I will get anywhere with Symantec as they will try and push me to use their BMR which is too complicated and cumbersome compared to Rear.


gdha commented at 2014-09-09 07:16:

Hi - see issue #454 to get some insight in the problems you have encountered. I believe they are the same. Is there any reason why you added NBU stuff into the local.conf file? That is not necessary as rear should have sufficient knowledge what to pull in. If not, then let us know.

kichoc commented at 2014-09-10 05:49:

Thanks for your reply but unfortunately i don't think issue 454 is the problem here.
There are no incrementals setup for the policy i am using to restore from, only full backups are performed.
In regards to the NBU stuff in my local.conf i added that in one of the attempts to get this thing to work so will remove as it made no difference.
Rear works great over netfs on both my test servers but i just can't get it to work with Netbackup on two different versions 6.5 and 7.5.

wzwei commented at 2014-09-10 08:51:


the server cannot start all the needed services. But it does boot partially. So there should be a /var/log/messages file containing hints what it is missing. Could you boot the machine from some Live CD and get the messages log file from the servers disk.

gdha commented at 2014-09-10 11:27:

@kichoc You could use the rear iso to boot from to further investigate your / file system. Inspect the log file of rear to find out if selinux tagging was performed or not?

kichoc commented at 2014-09-11 04:17:

Haven't have a chance to run this again and check the logs today but i can tell you that there definitely was NO selinux tagging occurring as this requires an extra reboot after the recover. I wrote this in my initial post as i asked the question should it occur on both NBU and netfs recovers as it only occurs with netfs here.

kichoc commented at 2014-09-17 01:05:

Tested this again and no .autorelabel file is created under /mnt/local as there is with netfs.
Created one after the netbackup restored completed but still didn't work but would not boot at all.
Giving up with using NBU and will stick with netfs.

[Export of Github issue for rear/rear.]