#1904 Issue closed: chroot bash test failed

Labels: support / question, fixed / solved / done

nieberad opened issue at 2018-08-24 07:55:

Relax-and-Recover (ReaR) Issue Template

Fill in the following items before submitting a new issue
(quick response is not guaranteed with free support):

  • ReaR version ("/usr/sbin/rear -V"): Relax-and-Recover 2.00 / Git

  • OS version ("cat /etc/rear/os.conf" or "lsb_release -a" or "cat /etc/os-release"): Red Hat Enterprise Linux Server release 5.9 (Tikanga)

  • ReaR configuration files ("cat /etc/rear/site.conf" and/or "cat /etc/rear/local.conf"):

# Default is to create Relax-and-Recover rescue media as ISO image
# set OUTPUT to change that
# set BACKUP to activate an automated (backup and) restore of your data
# Possible configuration values can be found in /usr/share/rear/conf/default.conf
# This file (local.conf) is intended for manual configuration. For configuration
# through packages and other automated means we recommend creating a new
# file named site.conf next to this file and to leave the local.conf as it is. 
# Our packages will never ship with a site.conf.
BACKUP_PROG_EXCLUDE=("${BACKUP_PROG_EXCLUDE[@]}" '/media' '/var/tmp' '/var/crash' '/rear_backup' '/tmp' '/hana')
  • Hardware (PC or PowerNV BareMetal or ARM) or virtual machine (KVM guest or PoverVM LPAR): HP GL360

  • System architecture (x86 compatible or PPC64/PPC64LE or what exact ARM device): x86

  • Firmware (BIOS or UEFI or Open Firmware) and bootloader (GRUB or ELILO or Petitboot):

  • Storage (lokal disk or SSD) and/or SAN (FC or iSCSI or FCoE) and/or multipath (DM or NVMe):

First tried NFS, then local disk for temp storage

  • Description of the issue (ideally so that others can reproduce it):
BUG in /usr/share/rear/build/default/980_verify_rootfs.sh:
'ROOTFS_DIR '/home/rear_backup/rear.EIhIZpeycV11717/rootfs' is broken, chroot bash test failed.'
  • Work-around, if any:

nieberad commented at 2018-08-24 09:32:

[root@m500356 ~]# chroot /rear_backup/rear.nTacClGBVf29196/rootfs/ bash -c true
chroot: cannot run command `bash': No such file or directory
[root@m500356 ~]# ls -ltr /rear_backup/rear.nTacClGBVf29196/rootfs/bin/bash
-rwxr-xr-x 1 root root 801816 Sep 25 2014 /rear_backup/rear.nTacClGBVf29196/rootfs/bin/bash

It exists, so I dunno, kinda baffling to me.

nieberad commented at 2018-08-24 09:33:

[root@m500356 ~]# cat .bash_profile 
# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
    . ~/.bashrc

# User specific environment and startup programs


export PATH

gdha commented at 2018-08-25 09:10:

@nieberad guessing this is related to #1905, no?
Try first to create a rescue image in debug mode:

rear -vdD mkrescue

and check the log file first. The real error will pop up somewhere.

gdha commented at 2018-09-24 15:07:

@nieberad Did you check the log file of rear to see what exactly went wrong?

jsmeix commented at 2018-09-28 07:32:

No news is good news.

[Export of Github issue for rear/rear.]