#2366 Issue closed: REAR with EMC networker

Labels: support / question, fixed / solved / done

IT-Guy-1973 opened issue at 2020-04-14 18:10:

Relax-and-Recover (ReaR) Issue Template

Fill in the following items before submitting a new issue
(quick response is not guaranteed with free support):

  • ReaR version ("/usr/sbin/rear -V"):

  • OS version ("cat /etc/rear/os.conf" or "lsb_release -a" or "cat /etc/os-release"):

  • ReaR configuration files ("cat /etc/rear/site.conf" and/or "cat /etc/rear/local.conf"):

  • Hardware (PC or PowerNV BareMetal or ARM) or virtual machine (KVM guest or PoverVM LPAR):

  • System architecture (x86 compatible or PPC64/PPC64LE or what exact ARM device):

  • Firmware (BIOS or UEFI or Open Firmware) and bootloader (GRUB or ELILO or Petitboot):

  • Storage (local disk or SSD) and/or SAN (FC or iSCSI or FCoE) and/or multipath (DM or NVMe):

  • Storage layout ("lsblk -ipo NAME,KNAME,PKNAME,TRAN,TYPE,FSTYPE,SIZE,MOUNTPOINT" or "lsblk" as makeshift):

  • Description of the issue (ideally so that others can reproduce it):

Hello REAR community,

We have EMC networker used as the backup solution in our environment. I am trying to integrate REAR into that. So I included the following in the site.conf file.

# cat site.conf | grep -v "^#"
BACKUP_PROG_INCLUDE=( '/boot'  '/'  'swap' '/dev')

I know the Networker running in this server is working fine and the regular backups are been done.
So when I ran the "rear -vD mkbackup" as root on the command line I got the following error.

# rear -vD mkbackup
Relax-and-Recover 1.17.2 / Git
Using log file: /var/log/rear/rear-lnxjump01.log
Creating disk layout
Excluding mountpoint /nmon_data. (MANUAL_INCLUDE mode)
Creating root filesystem layout
EMC Networker will recover these filesystems: / /nmon_data /boot
Copying files and directories
Copying binaries and libraries
Copying kernel modules
Creating initramfs
Making ISO image
Wrote ISO image: /var/lib/rear/output/rear-lnxjump01.iso (141M)
Saving result files with NSR (EMC NetWorker)
ERROR: Could not save result files with save
Aborting due to an error, check /var/log/rear/rear-lnxjump01.log for details

Looking at the log I see this:

Trace 0: /usr/sbin/rear:251 main
Trace 1: /usr/share/rear/lib/mkbackup-workflow.sh:24 WORKFLOW_mkbackup
Trace 2: /usr/share/rear/lib/framework-functions.sh:70 SourceStage
Trace 3: /usr/share/rear/lib/framework-functions.sh:31 Source
Trace 4: /usr/share/rear/output/NSR/default/95_nsr_save_result_files.sh:48 source
Trace 5: /usr/share/rear/lib/_input-output-functions.sh:132 StopIfError
++ echo 'Message: Could not save result files with save'
Message: Could not save result files with save

Any ideas why this is happening? I will attach the complete log.

Thank you for all your support given so far for my other support cases.

  • Workaround, if any:

  • Attachments, as applicable ("rear -D mkrescue/mkbackup/recover" debug log files):

To paste verbatim text like command output or file content,
include it between a leading and a closing line of three backticks like

verbatim content

IT-Guy-1973 commented at 2020-04-14 23:21:

So I figured out what the problem is (I hope) but not the solution. REAR is writing to the Networker storage pool "Default" but our pool name is A0C3-S. I do not know where I should change that on REAR.


IT-Guy-1973 commented at 2020-04-15 00:24:

Hello Support,

I was able to point REAR to the correct pool by changing the following parameter to the value shown.


However, I have a query which I will post as a separate issue by closing this issue.

Thank you,

[Export of Github issue for rear/rear.]